Element.Parameter(BuiltInParameter) Property

ElementParameter(BuiltInParameter) Property

Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Parameter this[
	BuiltInParameter parameterId
] { get; }
Public ReadOnly Property Parameter ( 
	parameterId As BuiltInParameter
) As Parameter
	Get
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
	Parameter^ get (BuiltInParameter parameterId);
}
member Parameter : Parameter with get

Parameters

parameterId  BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.
See Also