Curve.MakeUnbound Method

CurveMakeUnbound Method

Makes this curve unbound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void MakeUnbound()
Public Sub MakeUnbound
public:
void MakeUnbound()
member MakeUnbound : unit -> unit 
Remarks
If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.
See Also