BeamSystem.Create(Document, IList<Curve>, SketchPlane, Int32) Method

BeamSystemCreate(Document, IListCurve, SketchPlane, Int32) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	SketchPlane sketchPlane,
	int curveIndexForDirection
)
Public Shared Function Create ( 
	document As Document,
	profile As IList(Of Curve),
	sketchPlane As SketchPlane,
	curveIndexForDirection As Integer
) As BeamSystem
public:
static BeamSystem^ Create(
	Document^ document, 
	IList<Curve^>^ profile, 
	SketchPlane^ sketchPlane, 
	int curveIndexForDirection
)
static member Create : 
        document : Document * 
        profile : IList<Curve> * 
        sketchPlane : SketchPlane * 
        curveIndexForDirection : int -> BeamSystem 

Parameters

document  Document
 
profile  IListCurve
 
sketchPlane  SketchPlane
 
curveIndexForDirection  Int32
 

Return Value

BeamSystem
See Also