AnalyticalLinkType.RotationY Property

AnalyticalLinkTypeRotationY Property

Fixity of rotation around Y.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public AnalyticalFixityState RotationY { get; set; }
Public Property RotationY As AnalyticalFixityState
	Get
	Set
public:
property AnalyticalFixityState RotationY {
	AnalyticalFixityState get ();
	void set (AnalyticalFixityState value);
}
member RotationY : AnalyticalFixityState with get, set

Property Value

AnalyticalFixityState
Exceptions
ExceptionCondition
ArgumentException When setting this property: The fixity state rotationY is not valid for Analytical Link Type parameters.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also