Revit 2025.3 API
PartGet |
Gets a collection of elements from which this Part is created by the PartMaker.
May return more than one source only if there is merge involved somewhere in the history of this Part.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ICollection<LinkElementId> GetSourceElementIds()
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
public: ICollection<LinkElementId^>^ GetSourceElementIds()
member GetSourceElementIds : unit -> ICollection<LinkElementId>
Return Value
ICollectionLinkElementIdThe collection of elements

A source element is one of the elements in the original file that the PartMaker uses to create a Part.
For example, a floor or a wall used to create a Part can be called a source element.
See Also