RebarCouplerError Enumeration

RebarCouplerError Enumeration

Error states for the Rebar Coupler

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarCouplerError
Public Enumeration RebarCouplerError
public enum class RebarCouplerError
type RebarCouplerError
Members
Member nameValueDescription
ArcsHaveDifferentCenters16 Cannot place rebar couplers on arcs with different centers.
ArcsHaveDifferentRadii15 Cannot place rebar couplers on arcs with different radii.
ArcToStraightSegment17 Cannot connect by coupler a straight segment with an arc segment.
BarSegementsAreNotParallel6 The selected legs are not aligned.
BarSegmentsAreNotOnSameLine7 The selected legs are not aligned.
BarSegmentSmallerThanEngagement13 The selected leg is shorter than the bar engagement.
BarsNotTouching3 The selected ends of the bars are too far apart.
BendingPlanesAreNotParallel18 The bending planes of the connected bars are not parallel. This will be returned when connecting two shape-driven rebars whose bending planes are not parallel and the bar curves that need to be connected are not aligned.
CurvesOtherThanLine12 Cannot place rebar couplers on circular legs.
DifferentLayout2 The rebar sets have different numbers of bars.
InconsistentShape8 One of the selected bars has an incorrect shape.
IncorrectEndTreatmentCoupler5 The coupler cannot be placed at an end that already has a coupler.
IncorrectEndTreatmentHook4 The coupler cannot be placed at an end that already has a hook.
IncorrectInputData1 Cannot place rebar coupler.
InvalidDiameter9 The selected coupler type cannot be applied to the selected bar size(s).
ValidationSuccessfuly0 Bars can be coupled
VaryingDistanceBetweenDistributionsBars14 All the bars from the selected sets, which need to be connected, must be separated by the same distance.
See Also