ParameterSetIterator Class

ParameterSetIterator Class

An iterator to a parameter set.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBParameterSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class ParameterSetIterator : APIObject, 
	IEnumerator
Public MustInherit Class ParameterSetIterator
	Inherits APIObject
	Implements IEnumerator
public ref class ParameterSetIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type ParameterSetIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The ParameterSetIterator type exposes the following members.

Constructors
 NameDescription
Public methodParameterSetIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the set.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also