ParameterSetIterator Class

ParameterSetIterator Class

An iterator to a parameter set.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBParameterSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class ParameterSetIterator : APIObject, 
	IEnumerator
Public MustInherit Class ParameterSetIterator
	Inherits APIObject
	Implements IEnumerator
public ref class ParameterSetIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type ParameterSetIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The ParameterSetIterator type exposes the following members.

Constructors
 NameDescription
Public methodParameterSetIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the set.
Top
See Also