AnalyzeAs Enumeration

AnalyzeAs Enumeration

Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum AnalyzeAs
Public Enumeration AnalyzeAs
public enum class AnalyzeAs
type AnalyzeAs
Members
Member nameValueDescription
Gravity1 Interpreted as Gravity (support going down).
GravityLateral10 Wall interpreted as Gravity and Lateral
Hanger0 A hanging Element.
Lateral2 Interpreted as Lateral (support going across).
Mat4 Floor interpreted as Mat Foundation, or general foundation.
NotApplicable8 Analyze As is not applicable.
NotForAnalysis7 Element is not for Analysis.
SlabOneWay3 Floor interpreted as Slab One-Way.
SlabOnGrade5 Floor interpreted as Slab on a Grade.
SlabTwoWay9 Floor interpreted as Slab Two-Way.
See Also