MEPCurve.ReferenceLevel Property

MEPCurveReferenceLevel Property

The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Level ReferenceLevel { get; set; }
Public Property ReferenceLevel As Level
	Get
	Set
public:
property Level^ ReferenceLevel {
	Level^ get ();
	void set (Level^ value);
}
member ReferenceLevel : Level with get, set

Property Value

Level
Remarks
This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.
See Also