RevitLinkOptions Class

RevitLinkOptions Class

This class contains the options in use when creating or loading a Revit link.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RevitLinkOptions : IDisposable
Public Class RevitLinkOptions
	Implements IDisposable
public ref class RevitLinkOptions : IDisposable
type RevitLinkOptions = 
    class
        interface IDisposable
    end

The RevitLinkOptions type exposes the following members.

Constructors
 NameDescription
Public methodRevitLinkOptions(Boolean) Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public methodRevitLinkOptions(RevitLinkOptions) Constructs a new copy of the input RevitLinkOptions object.
Public methodRevitLinkOptions(Boolean, WorksetConfiguration) Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.
Top
Properties
 NameDescription
Public propertyIsRelative The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RevitLinkOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetWorksetConfiguration Gets the set of worksets to open when creating the link.
Public methodSetWorksetConfiguration Sets the set of worksets to open when creating the link.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also