Revit 2025.3 API
DocumentLoad |
Loads an entire family and all its types/symbols into the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool LoadFamily( string filename )
Public Function LoadFamily ( filename As String ) As Boolean
public: bool LoadFamily( String^ filename )
member LoadFamily : filename : string -> bool
Parameters
- filename String
- The fully qualified filename of the Family file, usually ending in .rfa.
Return Value
BooleanTrue if the entire family was loaded successfully into the project, otherwise False.

Exception | Condition |
---|---|
ArgumentException | Thrown when filename is or empty. |

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.
See Also