LinkedFileStatus Enumeration

LinkedFileStatus Enumeration

Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum LinkedFileStatus
Public Enumeration LinkedFileStatus
public enum class LinkedFileStatus
type LinkedFileStatus
Members
Member nameValueDescription
CanBeUpgraded4 The linked point cloud file is obsolete and can be indexed into new format.
Imported2 The element represented by this value was imported into Revit rather than linked into Revit.
InClosedWorkset5 The linked file is in a closed workset and will not be displayed.
Invalid-1 This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
Loaded0 The link is loaded.
LocallyUnloaded6 The linked file is unloaded for the specific user. (If the linked file is both unloaded for the specific user and unloaded for all users, the link will report LinkedFileStatus.Unloaded.)
NotFound3 The linked file was not able to be found the last time Revit tried to load it.
Unloaded1 The link is unloaded.
See Also