AnalyticalSurfaceBase.SketchId Property

AnalyticalSurfaceBaseSketchId Property

Sketch associated to this Revit element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
	Get
public:
property ElementId^ SketchId {
	ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
Remarks
Analytical Element may not have a valid sketch. To edit the sketch profile you can use SetOuterContour(CurveLoop) or [!:Autodesk::Revit::DB::SketchEditScope].
See Also