Solid.ComputeCentroid Method

SolidComputeCentroid Method

Returns the Centroid of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ ComputeCentroid()
Public Function ComputeCentroid As XYZ
public:
XYZ^ ComputeCentroid()
member ComputeCentroid : unit -> XYZ 

Return Value

XYZ
The XYZ point of the Centroid of this solid.
Remarks
Calculates the centroid of the solid using an approximation, with an accuracy suitable for architectural purposes. This will correspond only with the center of gravity if the solid represents a homogeneous structure of a single material.
See Also