Revit 2025.3 API
MEPSystem |
This enumeration is used to classify MEP connectors and systems
and drives certain behavior for a particular system type
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax

Member name | Value | Description |
---|---|---|
CableTrayConduit | 32 | Indicates the default type for cable trays and conduits |
Communication | 14 | An electrical circuit classified as communication |
CondensateDrain | 15 | Reserved for future use |
Controls | 13 | An electrical circuit classified as controls |
DataCircuit | 5 | An electrical data circuit |
DomesticColdWater | 20 | A cold water piping system |
DomesticHotWater | 19 | A hot water piping system |
ExhaustAir | 3 | Obsolete classification not used anymore |
FireAlarm | 11 | An electrical fire alarm circuit |
FireProtectDry | 24 | A dry fire protection system |
FireProtectOther | 26 | A user defined fire protection system |
FireProtectPreaction | 25 | A preaction fire protection system |
FireProtectWet | 23 | A wet fire protection system |
Fitting | 28 | Reserved for application usage, used for UI filtering in Family Editor |
Global | 29 | Reserved for application usage, used for UI filtering in Family Editor |
NurseCall | 12 | An electrical circuit classified as nurse call |
OtherAir | 4 | An user classified air duct system |
OtherPipe | 22 | An user classified piping system |
PowerBalanced | 30 | Equivalent with PowerCircuit |
PowerCircuit | 6 | An electrical circuit |
PowerUnBalanced | 31 | Equivalent with PowerCircuit |
Recirculation | 21 | Reserved for future use |
ReturnAir | 2 | A return air duct system |
ReturnHydronic | 8 | A hydronic return piping system |
Sanitary | 16 | A sanitary piping system |
Security | 10 | An electrical security circuit |
Storm | 18 | Reserved for future use |
SupplyAir | 1 | A supply air duct system |
SupplyHydronic | 7 | A hydronic supply piping system |
SwitchTopology | 27 | An electrical switch system |
Telephone | 9 | An electrical circuit classified as telephone |
UndefinedSystemClassification | 0 | A system classification not yet defined |
Vent | 17 | A piping ventilation system |
See Also