WallSweepInfo.Id Property

WallSweepInfoId Property

The id of the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public int Id { get; set; }
Public Property Id As Integer
	Get
	Set
public:
property int Id {
	int get ();
	void set (int value);
}
member Id : int with get, set

Property Value

Int32
If the wall sweep belongs to a vertically compound structure, this must be a non-negative value. If the wall sweep belongs to a sweep defined outside of compound structures by UI or API the id will typically be -1 and is not used.
See Also