Revit 2025.3 API
Data |
This class is used to regsiter an application-supplied object that implements IDataConversionMonitor.
Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument.
When the scope object is destroyed, that object is unregistered.

SystemObject
Autodesk.Revit.DBDataConversionMonitorScope
Autodesk.Revit.DBDataConversionMonitorScope
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The DataConversionMonitorScope type exposes the following members.

Name | Description | |
---|---|---|
![]() | DataConversionMonitorScope | The only constructor. Expects a valid pointer to IDataConversionMonitor. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DataConversionMonitorScope |
See Also