LightAndMaterialAccuracyMode Enumeration

LightAndMaterialAccuracyMode Enumeration

An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum LightAndMaterialAccuracyMode
Public Enumeration LightAndMaterialAccuracyMode
public enum class LightAndMaterialAccuracyMode
type LightAndMaterialAccuracyMode
Members
Member nameValueDescription
Advanced2 Soft shadows and soft reflections from semi-rough materials will be rendered with a high quality level. This is the standard setting that you typically want to rely on for final high quality renderings.
Simplified1 Rough and semi-rough materials are approximated. Consequently, materials may look more shinier than expected. Lighting is approximated so shadows will lack in details.
See Also