BuiltInFailures.GridFailures Class

BuiltInFailuresGridFailures Class

Failures about Grid.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresGridFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class GridFailures
Public NotInheritable Class GridFailures
public ref class GridFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GridFailures = class end

The BuiltInFailuresGridFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberGridEndSegmentsLengthTooShort The end segment length for a grid must be at least [Length Value]
Public propertyStatic memberGridInGridChainCannotMirror A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
Public propertyStatic memberGridlineAxisTooClose Axis of gridlines should not change order or be closer than [Value] to each other.
Public propertyStatic memberGridlineAxisTooFar Axis of gridlines should not be further than [Value] to each other.
Top
See Also