BehaviorType Enumeration

BehaviorType Enumeration

An enumerated type listing all the behavior type for MEP Components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum BehaviorType
Public Enumeration BehaviorType
public enum class BehaviorType
type BehaviorType
Members
Member nameValueDescription
BaseObject1,024 BehaviorType is Base Object
Bend2 BehaviorType is Bend
Branch4 BehaviorType is Branch
BreakInto32 BehaviorType is Break Into
Coupling2,097,152 BehaviorType is Coupling
Damper16,777,216 BehaviorType is a round centreline tap on oval straight
ElectricalBaseObject65,536 BehaviorType is Electrical Base Object
EndCap2,048 BehaviorType is End Cap
Flange8,192 BehaviorType is Flange
Flat_Tap1,048,576 BehaviorType is a flat tap on flat surface, eg. rectangular straight or flat-side of oval straight
Flex262,144 BehaviorType is Flex
Hanger524,288 BehaviorType is Hanger
Inline16 BehaviorType is Inline
Intersection8 BehaviorType is Intersection
Invalid0 BehaviorType is Invalid
MechanicalCoupling16,384 BehaviorType is Mechanical Coupling
Normal1 BehaviorType is Normal
OrientToCenterLine128 BehaviorType is Orient to CenterLine
OrientToFace256 BehaviorType is Orient to Face
OrientToObject64 BehaviorType is Orient to Object
Oval_CentreLine_Tap8,388,608 BehaviorType is a round centreline tap on oval straight
Round_CentreLine_Tap4,194,304 BehaviorType is a round centreline tap on round straight/pipe
Straight131,072 BehaviorType is Straight
SystemMember512 BehaviorType is System Member
Valve4,096 BehaviorType is Valve
VerticalBend32,768 BehaviorType is Vertical Bend
See Also