InSessionPrintSetting Class

InSessionPrintSetting Class

Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBInSessionPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class InSessionPrintSetting : IPrintSetting, 
	IDisposable
Public Class InSessionPrintSetting
	Implements IPrintSetting, IDisposable
public ref class InSessionPrintSetting : IPrintSetting, 
	IDisposable
type InSessionPrintSetting = 
    class
        interface IPrintSetting
        interface IDisposable
    end

The InSessionPrintSetting type exposes the following members.

Properties
 NameDescription
Public propertyPrintParametersReturns the Parameters of Print Setup.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the InSessionPrintSetting
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The in-session PrintSetting can't be stored in document.
See Also