BuiltInFailures.ElectricityFailures Class

BuiltInFailuresElectricityFailures Class

Failures related to electrical system and circuits.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresElectricityFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ElectricityFailures
Public NotInheritable Class ElectricityFailures
public ref class ElectricityFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElectricityFailures = class end

The BuiltInFailuresElectricityFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberFamilyMismatchCircuitDisconnected The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
Public propertyStatic memberInvalidPoleNumber The panel is single phase [wire] wires. The number of poles can not be larger than [value].
Public propertyStatic memberInvalidPoleNumberInIsolatedPanel The panel is an isolated panel. The number of poles should equal to [value].
Public propertyStatic memberInvalidSpareLoad The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.
Top
See Also