FabricationRodInfo.GetBearerExtension Method

FabricationRodInfoGetBearerExtension Method

Gets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double GetBearerExtension(
	int rodIndex
)
Public Function GetBearerExtension ( 
	rodIndex As Integer
) As Double
public:
double GetBearerExtension(
	int rodIndex
)
member GetBearerExtension : 
        rodIndex : int -> float 

Parameters

rodIndex  Int32
The index of the rod.

Return Value

Double
Exceptions
ExceptionCondition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The hanger is not a bearer hanger.
See Also