ExternalResourceReference(Guid, IDictionary<String, String>, String, String) Constructor

ExternalResourceReference(Guid, IDictionaryString, String, String, String) Constructor

Initializes a new instance of the ExternalResourceReference class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ExternalResourceReference(
	Guid serverId,
	IDictionary<string, string> referenceInformation,
	string version,
	string inSessionPath
)
Public Sub New ( 
	serverId As Guid,
	referenceInformation As IDictionary(Of String, String),
	version As String,
	inSessionPath As String
)
public:
ExternalResourceReference(
	Guid serverId, 
	IDictionary<String^, String^>^ referenceInformation, 
	String^ version, 
	String^ inSessionPath
)
new : 
        serverId : Guid * 
        referenceInformation : IDictionary<string, string> * 
        version : string * 
        inSessionPath : string -> ExternalResourceReference

Parameters

serverId  Guid
 
referenceInformation  IDictionaryString, String
 
version  String
 
inSessionPath  String
 
See Also