FabricationRodInfo.GetRodStructureExtension Method

FabricationRodInfoGetRodStructureExtension Method

Gets the length of the rod's top extension into structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double GetRodStructureExtension(
	int rodIndex
)
Public Function GetRodStructureExtension ( 
	rodIndex As Integer
) As Double
public:
double GetRodStructureExtension(
	int rodIndex
)
member GetRodStructureExtension : 
        rodIndex : int -> float 

Parameters

rodIndex  Int32
The rod index.

Return Value

Double
Returns the extension length that will be applied if the rod is attached to structure.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
See Also