BoundaryConditions.GetCurve Method

BoundaryConditionsGetCurve Method

Returns curve that define geometry of the line boundary conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Curve GetCurve()
Public Function GetCurve As Curve
public:
Curve^ GetCurve()
member GetCurve : unit -> Curve 

Return Value

Curve
Exceptions
ExceptionCondition
InvalidObjectException Thrown when BoundaryConditions is not a BoundaryConditionsType::Line type.
Remarks
Boundary conditions should be BoundaryConditionsType::Line type. Otherwise exception is thrown.
See Also