Revit 2025.3 API
ElementDesign |
Returns the design option to which the element belongs.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public DesignOption DesignOption { get; }
Public ReadOnly Property DesignOption As DesignOption Get
public: property DesignOption^ DesignOption { DesignOption^ get (); }
member DesignOption : DesignOption with get
Property Value
DesignOption
If the element is not in a design option, i.e. in the main model, then this property will
return .
See Also