Revit 2025.3 API
Rebar |
Sets the distance from the RebarConstrainedHandle to the target Host Cover Element surface.
The RebarConstraintType of the RebarConstraint must be 'ToCover'.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetDistanceToTargetCover( double distanceToTargetCover )
Public Sub SetDistanceToTargetCover ( distanceToTargetCover As Double )
public: void SetDistanceToTargetCover( double distanceToTargetCover )
member SetDistanceToTargetCover : distanceToTargetCover : float -> unit
Parameters
- distanceToTargetCover Double
- The distance is given as an offset value, the sign of which depends on Host Cover direction.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The given value for distanceToTargetCover must be no more than 30000 feet in absolute value. |
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToCover'. |
See Also