Revit 2025.3 API
View |
Rename the current view sheet set.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool Rename( string newName )
Public Function Rename ( newName As String ) As Boolean
public: bool Rename( String^ newName )
member Rename : newName : string -> bool
Parameters
- newName String
- View sheet set name to be renamed as.
Return Value
BooleanFalse if Rename operation fails, otherwise True.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when the input name is already existed in current view sheet set list. |
See Also