Element.HasPhases Method

ElementHasPhases Method

Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool HasPhases()
Public Function HasPhases As Boolean
public:
bool HasPhases()
member HasPhases : unit -> bool 

Return Value

Boolean
True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.
Remarks
Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.
See Also