ExternalGeometryId Class

ExternalGeometryId Class

This class represents an identifier for geometry from external sources.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExternalGeometryId : IDisposable
Public Class ExternalGeometryId
	Implements IDisposable
public ref class ExternalGeometryId : IDisposable
type ExternalGeometryId = 
    class
        interface IDisposable
    end

The ExternalGeometryId type exposes the following members.

Constructors
 NameDescription
Public methodExternalGeometryId Constructs an ExternalGeometryId object holding the given external geometry identifier.
Top
Properties
 NameDescription
Public propertyId External geometry identifier.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalGeometryId
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Overrides ObjectEquals(Object))
Public methodGetHashCode Gets the hash code.
(Overrides ObjectGetHashCode)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidExternalGeometryId Checks whether a given string represents a valid ExternalGeometryId or not.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Operators
 NameDescription
Public operatorStatic memberEquality(ExternalGeometryId, ExternalGeometryId)Determines whether two ExternalGeometryIds are the same.
Public operatorStatic memberInequality(ExternalGeometryId, ExternalGeometryId)Determines whether two ExternalGeometryIds are different.
Top
See Also