DefaultOpenFromCloudCallback Class

DefaultOpenFromCloudCallback Class

A default callback that may be used to control Revit's behavior when opening a model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDefaultOpenFromCloudCallback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DefaultOpenFromCloudCallback : IOpenFromCloudCallback, 
	IDisposable
Public Class DefaultOpenFromCloudCallback
	Implements IOpenFromCloudCallback, IDisposable
public ref class DefaultOpenFromCloudCallback : IOpenFromCloudCallback, 
	IDisposable
type DefaultOpenFromCloudCallback = 
    class
        interface IOpenFromCloudCallback
        interface IDisposable
    end

The DefaultOpenFromCloudCallback type exposes the following members.

Constructors
 NameDescription
Public methodDefaultOpenFromCloudCallback Create a default open callback. Open latest by default for all scenarios.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DefaultOpenFromCloudCallback
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodOnOpenConflict A method called when the conflict is happen during the model opening.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also