BeamSystem.Create(Document, IList<Curve>, Level, Int32, Boolean) Method

BeamSystemCreate(Document, IListCurve, Level, Int32, Boolean) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	Level level,
	int curveIndexForDirection,
	bool is3d
)
Public Shared Function Create ( 
	document As Document,
	profile As IList(Of Curve),
	level As Level,
	curveIndexForDirection As Integer,
	is3d As Boolean
) As BeamSystem
public:
static BeamSystem^ Create(
	Document^ document, 
	IList<Curve^>^ profile, 
	Level^ level, 
	int curveIndexForDirection, 
	bool is3d
)
static member Create : 
        document : Document * 
        profile : IList<Curve> * 
        level : Level * 
        curveIndexForDirection : int * 
        is3d : bool -> BeamSystem 

Parameters

document  Document
 
profile  IListCurve
 
level  Level
 
curveIndexForDirection  Int32
 
is3d  Boolean
 

Return Value

BeamSystem
See Also