ModelCurve.Subcategory Property

ModelCurveSubcategory Property

The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public GraphicsStyle Subcategory { get; set; }
Public Property Subcategory As GraphicsStyle
	Get
	Set
public:
property GraphicsStyle^ Subcategory {
	GraphicsStyle^ get ();
	void set (GraphicsStyle^ value);
}
member Subcategory : GraphicsStyle with get, set

Property Value

GraphicsStyle
Remarks
If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.
See Also