Leader Class

Leader Class

A leader object that can be attached to annotation elements such as text notes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLeader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Leader : APIObject
Public Class Leader
	Inherits APIObject
public ref class Leader : public APIObject
type Leader = 
    class
        inherit APIObject
    end

The Leader type exposes the following members.

Properties
 NameDescription
Public propertyAnchor Anchor point of the Leader
Public propertyElbow Elbow point of the Leader.
Public propertyEnd End point of the Leader.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLeaderShape Geometric style of the leader
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of TextNote class.
See Also