Revit 2025.3 API
Shape |
The base class for geometry builder classes.

SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ShapeBuilder type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ShapeBuilder |
See Also