Revit 2025.3 API
Shape |
The base class for geometry builder classes.

SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ShapeBuilder type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ShapeBuilder |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also