LineScaling Enumeration

LineScaling Enumeration

An enumerated type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum LineScaling
Public Enumeration LineScaling
public enum class LineScaling
type LineScaling
Members
Member nameValueDescription
ModelSpace1 Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
PaperSpace2 Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
ViewScale0 Exporting lines as they were scaled by view scale. This option preserves visual fidelity.
Remarks
Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash. Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.
See Also