Revit 2025.3 API
Document |
The event arguments used by the DocumentSavedAs event.

SystemObject
SystemEventArgs
Autodesk.Revit.DB.EventsRevitAPIEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
Autodesk.Revit.DB.EventsDocumentSavedAsEventArgs
SystemEventArgs
Autodesk.Revit.DB.EventsRevitAPIEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
Autodesk.Revit.DB.EventsDocumentSavedAsEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The DocumentSavedAsEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Cancellable |
Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs) |
![]() | Document |
The document associated with the event.
(Inherited from RevitAPIPostDocEventArgs) |
![]() | IsSavingAsCentralFile | Indicates whether the document is to be saved as central file. |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs) |
![]() | OriginalPath | Original path of the document. |
![]() | Status |
Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).
(Inherited from RevitAPIPostEventArgs) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RevitAPIEventArgs) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | IsCancelled |
Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also