Revit 2025.3 API
Document |
The event arguments used by the DocumentSavedAs event.

SystemObject
SystemEventArgs
Autodesk.Revit.DB.EventsRevitAPIEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
Autodesk.Revit.DB.EventsDocumentSavedAsEventArgs
SystemEventArgs
Autodesk.Revit.DB.EventsRevitAPIEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
Autodesk.Revit.DB.EventsDocumentSavedAsEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The DocumentSavedAsEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsSavingAsCentralFile | Indicates whether the document is to be saved as central file. |
![]() | OriginalPath | Original path of the document. |

Name | Description | |
---|---|---|
See Also