BuiltInFailures.GeometryFailures Class

BuiltInFailuresGeometryFailures Class

Failures about GeometryFailures.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresGeometryFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class GeometryFailures
Public NotInheritable Class GeometryFailures
public ref class GeometryFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeometryFailures = class end

The BuiltInFailuresGeometryFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCannotFindClosest Cannot find closest points within lines.
Public propertyStatic memberConvertFaceRegionsToFacesCrashed Failed to replace an instance face with its face regions.
Public propertyStatic memberConvertFaceRegionsToFacesFailed Failed to replace an instance face with its face regions.
Public propertyStatic memberCurveAndSurfaceDoNotIntersect Curve and Surface do not intersect.
Public propertyStatic memberCurveDriverError Element's internal join data is corrupt.
Public propertyStatic memberCurveProjectTooShort The projection of the line in this view is too short to create a new Line
Public propertyStatic memberElementIsTooThin [Element] is too thin.
Public propertyStatic memberElementTooSmall Element is too small on screen
Public propertyStatic memberFailedReplaceCurveElemCurveDriver Failed to replace curve elem curve driver.
Public propertyStatic memberFailedUpdateCurveChain Failed to update curve chain.
Public propertyStatic memberFailToConvertLine Unable to convert lines
Public propertyStatic memberLineArcTangentFailure Can't keep arc element and straight line element tangent.
Public propertyStatic memberOffsetFaceFailed Failed to offset the face.
Public propertyStatic memberPolygonSegmentTooShort Polygon segment too short
Public propertyStatic memberSiteInvisible Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
Public propertyStatic memberSuccessToConvertLine Success to convert lines
Public propertyStatic memberSymbolicLineInvalidPlane Symbolic Element refers to a Work Plane with unacceptable normal.
Public propertyStatic memberTooManyFacesEdges This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.
Top
See Also