MeshFromGeometryOperationIssue Enumeration

MeshFromGeometryOperationIssue Enumeration

Issues encountered while constructing meshes as fallbacks for geometrical operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum MeshFromGeometryOperationIssue
Public Enumeration MeshFromGeometryOperationIssue
public enum class MeshFromGeometryOperationIssue
type MeshFromGeometryOperationIssue
Members
Member nameValueDescription
AllFine0 No issues were encountered. Issues of this type should not be present in MeshFromGeometryOperationResult.
CurveLoopsWithoutCurvesInInput4 Among curve loops expected as input parameters while building a mesh, some are not empty, but do not have any curves.
EmptyCurveLoopsInInput3 Among curve loops expected as input parameters while building a mesh, some are empty.
InputCurveLoopProblemWithFallback6 An unidentified problem with an input curve loop. A fallback is attempted.
InputCurveLoopWrongOpenFlag7 An input curve has incorrect open flag.
InternalError12 An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
InternalMissingError11 An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered.
InternalUtilityError10 An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
MissingCurveLoopsInInput2 While several curve loops were expected as one of the input parameters while building a mesh, some of them were not provided.
MissingCurvesInInputLoop9 An input curve loop has missing curves.
NonContinuousInputCurveLoop8 A non-continuous input curve loop. Either wrong curve flips or genuine gaps.
NonPlanarProfileLoop5 Among curve loops expected as input parameters while building a mesh, some are not planar.
NotSetYet13 An issue has not been set yet.
NoUsableCurveLoopsInInput1 While one or more curve loops were expected as one of the input parameters while building a mesh, no loops containing curves were provided.
NumberOfIssueTypes14 Not a code of some issue, but the number of known types of issues. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered
See Also