ListType Enumeration

ListType Enumeration

An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ListType
Public Enumeration ListType
public enum class ListType
type ListType
Members
Member nameValueDescription
ArabicNumbers3 The paragraph is a part of an ordered list with Arabic number headings.
Bullet2 The paragraph is a part of a bulleted list.
LowerCaseLetters4 The paragraph is a part of an ordered list with lower-case letter headings.
Mixed0 This value may be returned by FormattedText.GetListType() when there are multiple list types in the selected range.
None1 The paragraph is not a part of a list.
UpperCaseLetters5 The paragraph is a part of an ordered list with upper-case letter headings.
See Also