ViewDisplayBackgroundImageFlags Enumeration

ViewDisplayBackgroundImageFlags Enumeration

A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ViewDisplayBackgroundImageFlags
Public Enumeration ViewDisplayBackgroundImageFlags
public enum class ViewDisplayBackgroundImageFlags
type ViewDisplayBackgroundImageFlags
Members
Member nameValueDescription
FitToScreen1 The image is stretched in both directions
FixedAspectRatio2 The image is stretched but the ratio of its height to width is preserved.
None0 The image is displayed pixel-to-pixel
UseTiling4 The pixels of the background are filled by tiling of the image.
See Also