AnalysisDisplayStyle.GetDeformedShapeSettings Method

AnalysisDisplayStyleGetDeformedShapeSettings Method

Get deformed shape settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public AnalysisDisplayDeformedShapeSettings GetDeformedShapeSettings()
Public Function GetDeformedShapeSettings As AnalysisDisplayDeformedShapeSettings
public:
AnalysisDisplayDeformedShapeSettings^ GetDeformedShapeSettings()
member GetDeformedShapeSettings : unit -> AnalysisDisplayDeformedShapeSettings 

Return Value

AnalysisDisplayDeformedShapeSettings
Exceptions
ExceptionCondition
InvalidOperationException deformed shape settings were not created with the object.
See Also