ConnectorType Enumeration

ConnectorType Enumeration

An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ConnectorType
Public Enumeration ConnectorType
public enum class ConnectorType
type ConnectorType
Members
Member nameValueDescription
AllModes16,777,215 All connection modes
AnyEnd129 Any end connection type
BlankEnd128 Blank End type
Curve2 Curve connection type
End1 End connection type
EndSurface17 End or Surface connection type
Family49 Family connection type
Invalid0 Invalid connection type
Logical4 Logical connection type
MainSurface32 Main surface connection type
MasterSurface32 This value is deprecated and will be removed in a future version of Revit. Please use MainSurface instead.
NodeReference64 Reference to the layout node type
NonEnd30 Not end connection type
Physical19 Physical connection type
Reference8 Reference connection type
Super256 Connection between a sub-system and a super-system, such as a connection between supply and return sub-systems and a main hydronic piping system or an air system.
Surface16 Surface connection type
See Also