IDataConversionMonitor Interface

IDataConversionMonitor Interface

A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IDataConversionMonitor
Public Interface IDataConversionMonitor
public interface class IDataConversionMonitor
type IDataConversionMonitor = interface end

The IDataConversionMonitor type exposes the following members.

Methods
 NameDescription
Public methodGetVerbosity Reports requested verbosity level
Public methodProcessMessage 
Top
See Also