AssetProperty Class

AssetProperty Class

Represents a property of material.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualAssetProperty
    More

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AssetProperty : IDisposable
Public Class AssetProperty
	Implements IDisposable
public ref class AssetProperty : IDisposable
type AssetProperty = 
    class
        interface IDisposable
    end

The AssetProperty type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyNameGet the name of the AssetProperty
Public propertyNumberOfConnectedProperties The number of currently connected properties.
Public propertyTypeReturns the type of the AssetProperty
Top
Methods
 NameDescription
Public methodAddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
Public methodAddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
Public methodDisposeReleases all resources used by the AssetProperty
Public methodGetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
Public methodGetConnectedProperty Gets one connected property with specified index.
Public methodGetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
Public methodStatic memberGetTypeNameGet the name of the AssetProperty
Public methodIsEditable Check if property can be edited.
Public methodIsValidSchemaIdentifier Check that schema name is valid
Public methodRemoveConnectedAsset Removes the connected asset attached to this asset property if any.
Top
Remarks
AssetProperty is the base class or all other AssetProperty sub classes.
See Also
Inheritance Hierarchy