Revit 2025.3 API
External |
Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool CallingDocumentHasModelPath()
Public Function CallingDocumentHasModelPath As Boolean
public: bool CallingDocumentHasModelPath()
member CallingDocumentHasModelPath : unit -> bool
Return Value
BooleanTrue if the document has a defined ModelPath.

A project that is detached, or has not been saved to disk yet, will not have a ModelPath.
See Also