Document.GetCloudModelUrn Method

DocumentGetCloudModelUrn Method

A ForgeDM Urn identifying the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string GetCloudModelUrn()
Public Function GetCloudModelUrn As String
public:
String^ GetCloudModelUrn()
member GetCloudModelUrn : unit -> string 

Return Value

String
Exceptions
ExceptionCondition
RevitServerUnauthorizedException Thrown when cannot get data from ForgeDM.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it;
See Also