ProfilePlaneLocation Enumeration

ProfilePlaneLocation Enumeration

Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ProfilePlaneLocation
Public Enumeration ProfilePlaneLocation
public enum class ProfilePlaneLocation
type ProfilePlaneLocation
Members
Member nameValueDescription
End2Indicates the profile plane located at the End of the path curve.
MidPoint1Indicates the profile plane located at the Middle point of the path curve.
Start0Indicates the profile plane located at the start of the path curve.
Remarks
Use this enum in the NewSweep() method to create generic forms.
See Also