Revit 2025.3 API
External |
Various options affecting the behavior of an External Service

SystemObject
Autodesk.Revit.DB.ExternalServiceExternalServiceOptions
Autodesk.Revit.DB.ExternalServiceExternalServiceOptions
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ExternalServiceOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalServiceOptions | Constructs a new ExternalServiceOptions with default settings. |

Name | Description | |
---|---|---|
![]() | IsPublic | This property denotes a service as either public or private. |
![]() | IsRecordable | Indicates whether executions of the service is recorded in documents or not. |
![]() | IsSelfsynchronizing | Indicates whether the service's record of used services (in a particular document) can independently wary between local clients and the corresponding central model. It is then up to the service's owner to assure proper local-central synchronization. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SupportActivation | Indicates if the service supports activation/deactivation of the servers. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExternalServiceOptions |

Options are provided at the time of registering a service.
After a service is registered, the options cannot be changed.
See Also